Incorrect Kubernetes Metrics Collection

Incident Report for Ternary

Resolved

This incident has been resolved.
Posted Jul 08, 2022 - 06:45 PDT

Update

This issue has been resolved. Kubernetes metrics are now correctly being collected, and a backfill has been completed to bring in the data that was missed.
Posted Jul 08, 2022 - 06:43 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2022 - 23:21 PDT

Identified

We have identified an issue affecting the reported of kubernetes node costs beginning July 5, 2022. The cause is a metrics ingestion error resulting in the under-counting of the cpu capacity of Kubernetes nodes. The fix is underway.
Posted Jul 07, 2022 - 19:41 PDT
This incident affected: Ingestion (GCP Metrics).